Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2026 - 18:00 PDT
Scheduled
This announcement affects you if you access your Everbridge service from *.everbridge.net.
Planned Update The March product update includes enhancements, defect fixes, and other client-requested improvements for Everbridge 360, VCC, and Crisis Management.
Everbridge 360 • Single Sign-On configuration is now available at the organization level. • Users with access can now confirm or respond on behalf of contacts in Communications. • Polygon shape(s) used for geographic targeting is viewable in a widget on the Communication Details page.
Visual Command Center • Enterprise customers have access to AI Assistant to get product information more quickly inside Everbridge 360. • Assess Alerts more quickly by generating an AI-based analysis for a selected Alert.
UTC Start: 2 April 2026 1:00 AM End: 2 April 2026 3:00 AM
EASTERN U.S. Start: 1 April 2026 2026 9:00 PM End: 1 April 2026 2026 11:00 PM
WESTERN U.S Start: 1 April 2026 2026 6:00 PM End: 1 April 2026 2026 8:00 PM
Impact to Your Recipients or Contacts
This update does not change how your message recipients experience your Everbridge notifications.
Impact to You
We do not expect this update to affect your users who log into your Everbridge service.
Posted Mar 25, 2026 - 14:41 PDT
This scheduled maintenance affected: Contacts and Assets (Contact Uploads, CA Contact Data, UK Contact Data, US Contact Data, US2 Contact Data, US3 Contact Data), Using API (REST API), and Web Interface (Manager Portal, Member Portal).