Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 08, 2026 - 09:00 PDT
Scheduled
This announcement affects you if you access the Everbridge Suite Support Center, which hosts our branded user guides, knowledge base articles, microlearning content, release notes, and more.
Planned Update To further enhance the security of Everbridge learning resources and better protect customer content, we will be updating access to the Everbridge Support Center.
Beginning soon, most Support Center content will require authenticated access. Customers, partners, and other authorized users must sign in to view content. Access will be available through the Help & Support menu in the Manager Portal, or by signing in with existing Support Center credentials. Users can also sign up for their Support Center profile if they don’t already have one.
Access validation will confirm that the user is associated with an active Everbridge customer account. Content intended for broader, public audiences, such as Community and Nixle members, Public Safety information, and select general reference materials will still be available for users unassociated with customer accounts.
When UTC Start: 08 June 2026 4:00 PM End: 08 June 2026 4:30 PM
EASTERN U.S. Start: 08 June 2026 12:00 PM End: 08 June 2026 12:30 PM
WESTERN U.S Start: 08 June 2026 9:00 AM End: 08 June 2026 9:30 AM
Why We Are Making This Change This update is part of Everbridge’s ongoing commitment to strengthening platform security and protecting customer-related documentation resources from misuse or unauthorized access. By requiring authenticated access, Everbridge can better ensure that detailed technical documentation and other learning resources are available only to authorized users.
Action Required No immediate action is required if you already have access to the Everbridge platform. When accessing protected Support Center content after this change is implemented, users can either:
• Navigate to Support from the Manager Portal’s Help & Support Menu, which automatically logs the user into their Support Center profile, or creates a new profile if one doesn’t already exist. • Manually navigate to the Everbridge Support Center sign-in page to sign in with existing credentials or sign up for a Support Center profile.
Impact to Your Recipients or Contacts This update does not change how your message recipients experience your Everbridge notifications.
Impact to You • Accessing most Support Center content will require authentication. • Any bookmarks or direct links to protected Support Center pages may redirect you to a sign-in page before content is displayed.
This change does not affect the availability or operation of your Everbridge services.
Posted Jun 04, 2026 - 11:27 PDT
This scheduled maintenance affected: Using API (REST API), Web Interface (Manager Portal, Member Portal, VCC Portal), and Mobile Apps (Managebridge, Everbridge (EMA & EB360 Mobile)).