Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 27, 2026 - 18:00 PDT
Scheduled
This announcement affects you if you access your Everbridge service from *.everbridge.net.
Planned Update
The May product update includes enhancements, defect fixes, and other client-requested improvements for Everbridge 360, Communications, Visual Command Center, and changes to how users access Online Help.
Everbridge 360 • When configured, users can select from different MFA delivery options. • VCC Operator Console is a Core permission for Custom Roles. • Organization contacts can see that their email address is disabled in Member Portal.
Communications • View all recipient confirmation data from communications with resends in one consolidated view. • Communications Custom Reports with performance, delivery details, and recipient-level data.
Visual Command Center • Find KML and Shapefiles you upload to VCC in the Everbridge Layer Library. • Manage your ESRI Layer Library.
Changes to Online Help • Online Help content will now require user authentication before it can be viewed. See Everbridge Support Center for more details.
UTC Start: 28 May 2026 1:00 AM End: 28 May 2026 3:00 AM
EASTERN U.S. Start: 27 May 2026 9:00 PM End: 27 May 2026 11:00 PM
WESTERN U.S Start: 27 May 2026 6:00 PM End: 27 May 2026 8:00 PM
Impact to Your Recipients or Contacts
This update does not change how your message recipients experience your Everbridge notifications.
Impact to You
We do not anticipate any impact to your users during the deployment window. However, some services including ITA, iPaaS, and Secure Messaging may have intermittent disruptions of up to 10 minutes. If you encounter any issues, please wait 10 minutes and try again.
Posted May 20, 2026 - 13:49 PDT
This scheduled maintenance affected: Contacts and Assets (Contact Uploads, CA Contact Data, UK Contact Data, US Contact Data, US2 Contact Data, US3 Contact Data), Using API (REST API), and Web Interface (Manager Portal, Member Portal).