Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 17, 2025 - 18:00 PST
Scheduled
This announcement affects you if you access your Everbridge service from *.everbridge.net.
Planned Update
The December product update includes enhancements, defect fixes, and other client-requested improvements for Everbridge 360, Crisis Management, and Visual Command Center.
Everbridge 360 • Organizations will be able to configure the Interval Between Cycles to be greater than 60 minutes to up to one day on a Notification. • Administrators will be able to download a list of incident subscriptions with their subscribers as well as upload subscriptions via the UI and the API.
Crisis Management • Centralized, real-time task coordination during critical events. • Seamless access to governance-approved recovery strategies.
VCC • Filter Contacts in VCC by Contact Rules. • Watch Zone status indicator allows you to see if a Watch Zone is active or inactive.
UTC Start: 18 December 2025 2:00 AM End: 18 December 2025 4:00 AM
EASTERN U.S. Start: 17 December 2025 9:00 PM End: 17 December 2025 11:00 PM
WESTERN U.S Start: 17 December 2025 6:00 PM End: 17 December 2025 8:00 PM
Impact to Your Recipients or Contacts
This update does not change how your message recipients experience your Everbridge notifications.
Impact to You
We do not expect this update to affect your users who log into your Everbridge service.
Posted Dec 10, 2025 - 09:18 PST
This scheduled maintenance affected: Contacts and Assets (Contact Uploads, CA Contact Data, UK Contact Data, US Contact Data, US2 Contact Data, US3 Contact Data), Using API (REST API), and Web Interface (Manager Portal, Member Portal).