Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 24, 2026 - 18:00 PST
Scheduled
This announcement affects you if you access your Everbridge service from *.everbridge.eu.
Planned Update
The February product update includes enhancements, defect fixes, and other client-requested improvements for Everbridge 360, VCC, and Crisis Management:
Everbridge 360 • Configure the landing page for VCC operators in Custom Roles. • Organization Administrators can control AI message enhancements in organization settings. • Service accounts can now be provisioned with resource and action-based access controls, granting access only to the specific APIs and actions required. • Organizations can now provision DKIM keys for their custom domain or email address.
Visual Command Center • Employee Mobile Safety phone call events are now available as risk events in Visual Command Center.
Crisis Management • Event navigation and document management have been improved in Everbridge 360
UTC Start: 25 February 2026 2:00 AM End: 25 February 2026 4:00 AM
EASTERN U.S. Start: 24 February 2026 9:00 PM End: 24 February 2026 11:00 PM
WESTERN U.S Start: 24 February 2026 6:00 PM End: 24 February 2026 8:00 PM
Impact to Your Recipients or Contacts
This update does not change how your message recipients experience your Everbridge notifications.
Impact to You
We do not expect this update to affect your users who log into your Everbridge service.
Posted Feb 17, 2026 - 16:21 PST
This scheduled maintenance affected: Contacts and Assets (Contact Uploads, DE Contact Data), Using API (REST API), and Web Interface (Manager Portal, Member Portal).