Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 02, 2026 - 18:00 PDT
Scheduled
This announcement affects you if you access your Everbridge service from *.everbridge.eu and *.everbridge.net
Emergency Update
As part of our continuing commitment to securing your data and to accommodating projected product usage by our clients, Everbridge will be performing emergency infrastructure maintenance. We apologize for the short notice.
When
April 2 2024 6:00 PM PT/ 9:00 PM ET / April 3 2024 1:00 AM UTC
Impact to Your Recipients or Contacts
This update does not change how your message recipients experience your Everbridge notifications.
Impact to You
Some users may experience session interruptions during the maintenance window. Refresh your browser to restore session connections.
________________________________________
Deployment Window
START April 2 2024 6:00 PM PT/ 9:00 PM ET / April 3 2024 1:00 AM UTC
END April 2 2024 6:30 PM PT/ 9:30 PM ET / April 3 2024 1:30 AM UTC
Posted Apr 02, 2026 - 12:27 PDT
This scheduled maintenance affected: Web Interface (Manager Portal, Member Portal, VCC Portal).